Recover from Edge Node Initialization or Provisioning Failed#
This page describes how to recover a failed node during provisioning or initialization.
Symptom#
Edge Node can fail in two phases:
INITIALIZATION_FAILED
PROVISION_FAILED
Edge Orchestrator will provide the reason for the failure and the provisioning step of failure.
Cause#
Edge Node provisioning can fail for various reasons :
Network Issue
Network timeout
Network disruption during micro OS (µOS) download
Network disruption during OS download
Resource download (either OS or µOS) does not resume after a network disruption
Configuration Mismatch
Secure boot mismatch between Edge Orchestrator UI and Edge Node
Solution#
The Edge Orchestrator UI will indicate the step and reason for the initialization or provisioning failure.
Note
Automatic error recovery is not supported during remote onboarding and provisioning. Manual intervention is required following the steps below.
Recovery Steps for Network Issues#
Delete the configured Host in UI Delete Host
Reboot the Edge Node from the management console or power button
Edge Orchestrator will automatically start provisioning again; follow the process in Onboard Edge Nodes
Recovery Steps for Configuration Mismatch#
Delete the configured Host in UI Delete Host
Re-register the host following Register Edge Nodes in Edge Orchestrator and ensure configuration (Secure Boot) settings match between Edge Orchestrator UI and Edge Node
Reboot the Edge Node from the management console or power button
Edge Orchestrator will automatically start provisioning again; follow the process in Onboard Edge Nodes
Secure Boot Configuration#
For detailed Secure Boot information, see Secure Boot opt in feature
To configure Secure Boot:
Edge Orchestrator UI (during registration): Provision Host
Edge Node configuration: Onboard Edge Nodes